Bug #1278

Issues installing on Icinga on FreeBSD

Added by henrik almost 6 years ago. Updated over 5 years ago.

Status:ResolvedStart date:03/07/2011
Priority:NormalDue date:
Assignee:Wolfgang% Done:


Target version:-
Icinga Version:



I tried installing Icinga with idoutils following this guide:

There was a lot of problems running the configure script at first, complaining that it could not find the dbi libs.

So then I included this:

Then, configure ran smoothly.

Though, it crashed on make, giving misc errors when trying make idoutils.

Then I added this:

So my complete configure line was:
./configure --with-command-group=icinga-cmd --enable-idoutils --enable-ssl --includedir=/usr/local --with-dbi-lib=/usr/local/lib --with-dbi-inc=/usr/local/include

This solved my issue.

cd /usr/ports/devel/libtool22/ && make all install clean

Does not exist, but this does:
cd /usr/ports/devel/libtool/ && make all install clean

Hope this helps! :-)


#1 Updated by LarsEngels almost 6 years ago

The guide should be re-worked, as there's a FreeBSD port of Icinga now (net-mgmt/icinga).

#2 Updated by Wolfgang over 5 years ago

  • Status changed from New to Assigned
  • Assignee set to Wolfgang
  • % Done changed from 0 to 50

fixed in git master

#3 Updated by Wolfgang over 5 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 50 to 100

added hint to port

Also available in: Atom PDF